Joomla 1.5 component problems and fixes

Many owners of Joomla 1.5 installations may be encountering problems with components like JoomDoc, a document handler that allows for the website to offer downloadable documents to website visitors.

As technology advances, PHP versions change.  With developers no longer working much with Joomla 1.5 compatibility, the website owners start encountering problems, and see error messages on their websites when their visitors navigate to these components.

FIX:

If you are using a cPanel hosting panel, you should see an icon for PHP Version Manager, often located in the 1H Software tab.  Click on the icon.  You you now be able to navigate through your folders.  If you only have one website installed on your host, and it's a Joomla 1.5 platform, you can just choose the public_html folder. 

Once you locate the folder to adjust, you'll notice the various PHP versions that are available.  Your current PHP version at this date is probably a 5.3.xx or 5.4.xx that's set by default.  I've been dropping the version back to 5.2.17 with success.

Click the Save icon, and you should be good!

PHP Version Manager in cPanel hosting fixes JoomDoc error messages on Joomla 1.5